LOGIN
User Name
Password
Remember me


Register...Forgot password?
Main menu
Leagues
Gonzaga
Blue Max
Cartagena
King Me!
Wooden Ships...
VampiRing
Preferred site
Anno mille
You Play It - Forum message board
In this forum the players can exchange informations and comments on the games they are currently playing or post messages on new board games, card games, wargames, simulations, rpg or any other type of game or toy they like: puzzle, robots, monsters, space toys, lego, marble or even talk about your last barbie doll. Every one can read the messages, but in order to post new messages you must be a registered user. You can even use an RSSReader to follow our RSS feed .
Filters
Filter messages on:
FORUM'S ACTIVE TOPICS
Previous pageStart a new TopicNext page

Posting elapsed timePosted bySubject

1year 39days nochute [BM][OT] How to place plane
1year 39days imdog Re: [BM][OT] How to place plane
 1year 38days nochute Re: [BM][OT] How to place plane
  1year 38days TXWard Re: [BM][OT] How to place plane
   1year 37days Electro Re: [BM][OT] How to place plane
    1year 37days imdog Re: [BM][OT] How to place plane

1year 45days imdog [VA][CHA] Duke Parker's call
1year 45days Fineturno Re: [VA][CHA] Duke Parker's call

1year 64days Osgard [BM][OT] Surgery
1year 59days imdog Re: [BM][OT] Surgery

1year 59days imdog [BM][OT] greeting from far east

1year 93days Rammstein [BM][TOUR] league number: 10918. Points not awarded
1year 93days markrendl Re: [BM][TOUR] league number: 10918. Points not awarded
 1year 93days Rammstein Re: [BM][TOUR] league number: 10918. Points not awarded

1year 103days Swanto [WS&IM][BUG] I wuz robbed!
1year 102days Longneck Re: [WS&IM][BUG] I wuz robbed!
 1year 102days Swanto Re: [WS&IM][BUG] I wuz robbed!

1year 113days Morrigan31 [BM][OT] Withdrawal from a league not yet started
1year 107days Morrigan31 Re: [BM][OT] Withdrawal from a league not yet started
 1year 106days markrendl Re: [BM][OT] Withdrawal from a league not yet started
  1year 106days Morrigan31 Re: [BM][OT] Withdrawal from a league not yet started

1year 144days Swanto [WS&IM][OT] Conquerant
1year 139days derekticus Re: [WS&IM][OT] Conquerant
1year 138days Swanto Re: [WS&IM][OT] Conquerant
1year 114days SBGrad Re: [WS&IM][OT] Conquerant
 1year 113days Swanto Re: [WS&IM][OT] Conquerant

1year 163days Osgard [OT] Donation
1year 156days markrendl Re: [OT] Donation
 1year 141days Farmboy Re: [OT] Donation
  1year 141days dirtyed84 Re: [OT] Donation
   1year 125days Electro Re: [OT] Donation

1year 153days Swanto [WS&IM][OT] "no guns or crew available"
1year 152days Longneck Re: [WS&IM][OT] "no guns or crew available"
 1year 152days Swanto Re: [WS&IM][OT] "no guns or crew available"
  1year 151days Longneck Re: [WS&IM][OT] "no guns or crew available"

1year 159days jfmays [BM][IDEAS] Free For All

1year 179days Balordo [OT] Unreacheable site
1year 179days Swanto Re: [OT] Unreacheable site
1year 179days Balordo Re: [OT] Unreacheable site
 1year 179days Morrigan31 Re: [OT] Unreacheable site
  1year 179days Balordo Re: [OT] Unreacheable site
   1year 178days KapteinKnutsen Re: [OT] Unreacheable site
    1year 178days dcr66 Re: [OT] Unreacheable site
     1year 178days KapteinKnutsen Re: [OT] Unreacheable site
      1year 178days dcr66 Re: [OT] Unreacheable site
1year 176days BlackSheep Re: [OT] Unreacheable site
 1year 171days Balordo Re: [OT] Unreacheable site

1year 172days M1kel [WS&IM][IDEAS] Moving ship window on iPad
1year 172days dcr66 Re: [WS&IM][IDEAS] Moving ship window on iPad

1year 217days derekticus [WS&IM][CHA] Looking for a new Tall Ships Naval Challenge?

1year 242days Sabelkatten [BUG] More stuck games
1year 220days imdog Re: [BUG] More stuck games

1year 281days redpanda [CA][BUG] game stuck, league stuck
1year 281days imdog Re: [CA][BUG] game stuck, league stuck
 1year 231days redpanda Re: [CA][BUG] game stuck, league stuck
  1year 220days imdog Re: [CA][BUG] game stuck, league stuck

1year 270days mjk1964 [BM][BUG] league 10770
1year 269days markrendl Re: [BM][BUG] league 10770
 1year 267days mjk1964 Re: [BM][BUG] league 10770

2years 11days wetty11 [CA][BUG] Apparent auto-play not working
2years 4days bltzlfsk Re: [CA][BUG] Apparent auto-play not working
 1year 281days wetty11 Re: [CA][BUG] Apparent auto-play not working
  1year 281days imdog Re: [CA][BUG] Apparent auto-play not working


Previous pageStart a new TopicNext page

Note: content submitted to this forum is released under the Creative Commons license.
There's even another way to communicate

In our continous effort to bring you an outstanding service, we have also created a Yahoo! group. If you like, you can then join the Yahoo! group to exchange messages, files, and pictures, with the other players, and make us know your opinions using polls
If you have any other personal question, write us a mail to postmaster@youplay.it

Page generated in: 20.3125 milliseconds.